漏洞名称: Apache Camel camel-snakeyaml组件安全漏洞
CNNVD编号: CNNVD-201702-770
发布时间: 2017-02-22
更新时间: 2017-03-08
危害等级: 高危  高危
漏洞类型: 资料不足
威胁类型: 远程
CVE编号: CVE-2017-3159

Apache Camel是美国阿帕奇(Apache)软件基金会的一套开源的基于Enterprise Integration Pattern(企业整合模式,简称EIP)的集成框架。该框架提供企业集成模式的Java对象(POJO)的实现,且通过应用程序接口来配置路由和中介的规则。camel-snakeyaml是其中的一个基于Java开发的YAML解析器组件。

Apache Camel的camel-snakeyaml组件中存在安全漏洞。远程攻击者可利用该漏洞执行代码。以下版本受到影响:Apache Camel 2.14.4及之前的版本,2.17.0版本,2.17.1版本,2.17.2版本,2.17.3版本,2.17.4版本,2.18.0版本,2.18.1版本。

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://camel.apache.org/security-advisories.data/CVE-2017-3159.txt.asc

   
 

Apache Camel:2.14.4