【漏洞预警】CNNVD 关于Apache Struts2 S2-059安全漏洞的通报

发布时间:2020-08-14   

       近日,国家信息安全漏洞库(CNNVD)收到关于Apache Struts2 S2-059安全漏洞(CNNVD-202008-743、CVE-2019-0230)情况的报送。成功利用漏洞的攻击者可能对目标系统执行恶意代码。Apache Struts 2.0.0–Apache Struts 2.5.20等版本均受此漏洞影响。目前,Apache官方已经发布了版本更新修复了该漏洞。建议用户及时确认Apache Struts产品版本,如受影响,请及时采取修补措施。

一、漏洞介绍

       Apache Struts2是美国阿帕奇(Apache)软件基金会下属的Jakarta项目中的一个子项目,是一个基于MVC设计的Web应用框架。

       2020年8月13日,Apache官方发布安全公告,修复了一个远程代码执行漏洞,编号为S2-059 (CNNVD-202008-743、CVE-2019-0230)。该漏洞源于Apache Struts的框架在被强制使用时,会对标签的属性进行二次求值,最终导致远程代码执行。只有在Struts标签属性中强制使用OGNL表达式时,才能触发漏洞。

二、危害影响

       成功利用该漏洞的攻击者,可以在目标系统中执行恶意代码。Apache Struts 2.0.0–Apache Struts 2.5.20等版本均受此漏洞影响。

三、修复建议

       目前,Apache官方已经发布了版本更新修复了该漏洞。建议用户及时确认Apache Struts产品版本,如受影响,请及时采取修补措施。漏洞修补措施如下:

       更新到Struts 2.5.22以上版本

       http://struts.apache.org/download.cgi

       本通报由CNNVD技术支撑单位——内蒙古洞明科技有限公司、远江盛邦(北京)网络安全科技股份有限公司、天融信网络安全技术有限公司、北京长亭科技有限公司、北京山石网科信息技术有限公司、杭州安恒信息技术股份有限公司、北京启明星辰信息安全技术有限公司、北京圣博润高新技术股份有限公司等技术支撑单位提供支持。

       CNNVD将继续跟踪上述漏洞的相关情况,及时发布相关信息。如有需要,可与CNNVD联系。

       联系方式: cnnvd@itsec.gov.cn




漏洞预警快速查询