【漏洞预警】CNNVD 关于Redis代码注入漏洞的预警

发布时间:2022-03-22   

近日,国家信息安全漏洞库(CNNVD)收到关于Redis代码注入漏洞(CNNVD-202202-1622、CVE-2022-0543)情况的报送。成功利用此漏洞的攻击者,可在目标服务器远程执行恶意代码,进而控制目标服务器。Redis 5.x系列 5.0.14以下版本、Redis 6.x系列 6.0.16以下版本、Redis 7.x系列 7.0-rc2以下版本均受漏洞影响。目前,Redis官方已发布新版本修复了漏洞,请用户及时确认是否受到漏洞影响,尽快采取修补措施。

一、漏洞介绍

Redis是美国Redis Labs公司的一套开源的使用ANSI C编写、支持网络、可基于内存亦可持久化的日志型、键值(Key-Value)存储数据库。Redis存在代码注入漏洞,攻击者可利用该漏洞在未授权的情况下,构造恶意数据执行沙箱逃逸攻击,最终获取服务器最高权限。

二、危害影响

成功利用此漏洞的攻击者,可在目标服务器远程执行恶意代码,进而控制目标服务器。Redis 5.x系列 5.0.14以下版本、Redis 6.x系列 6.0.16以下版本、Redis 7.x系列 7.0-rc2以下版本均受漏洞影响。

三、修复建议

目前,Redis官方已发布新版本修复了漏洞,请用户及时确认是否受到漏洞影响,尽快采取修补措施。官方链接如下:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1005787

本通报由CNNVD技术支撑单位——华为技术有限公司、深信服科技股份有限公司、长亭科技股份有限公司、北京山石网科信息技术有限公司、新华三技术有限公司、北京知道创宇信息技术股份有限公司、北京华云安信息技术有限公司提供支持。

CNNVD将继续跟踪上述漏洞的相关情况,及时发布相关信息。如有需要,可与CNNVD联系。联系方式: cnnvdvul@itsec.gov.cn



漏洞预警快速查询

热点漏洞

更多