漏洞信息详情

Powie pforum sql插入漏洞

  • CNNVD编号:CNNVD-200205-118
  • 危害等级: 超危
  • CVE编号: CVE-2002-0287
  • 漏洞类型: 输入验证
  • 发布时间: 2002-02-16
  • 威胁类型: 远程
  • 更新时间: 2006-11-07
  • 厂        商: Powie
  • 漏洞来源: Jens Liebchen※ sec...

漏洞简介

pforum是采用php和mysql实现的WWW论坛。 Powie\'\'s PHP Forum 1.14易受sql插入攻击,攻击者可以未经验证获取管理员权限。 假设没有允许PHP的magic_quotes_gpc配置,用\"admin\'\' OR username=\'\'admin\"做用户名进行登录。如果确实存在admin用户,攻击者将非法以admin用户身份登录,无需口令验证。如果admin用户就是管理员,攻击者将获取论坛管理权限。 修改口令的表单处存在同样漏洞。当你遗失口令后,一般通过注册时登记的Email获取一个ID,用这个ID就可以修改自己的口令。攻击者访问changepass.php,提交如下ID,\"123\'\' or \'\'a\'\'=\'\'a\",于是可以任意修改口令。 由于论坛管理员无法访问php.ini,也就无法简单地修补该漏洞。需要WEB Server系统管理员的帮助。注意,缺省安装后magic_quotes_gpc就是允许的。

漏洞公告

临时解决方法: 如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:

* 在php.ini中默认允许magic_quotes_gpc。 厂商补丁: Powie ----- 目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://www.powie.de/pm/pmagic.php?pmagic=pforum

参考网址

来源: www.powie.de 链接:http://www.powie.de/news/index.php 来源: BUGTRAQ 名称: 20020216 pforum: mysql-injection-bug 链接:http://marc.theaimsgroup.com/?l=bugtraq&m=101389284625019&w=2 来源: BID 名称: 4114 链接:http://www.securityfocus.com/bid/4114 来源: XF 名称: pforum-quotes-sql-injection(8203) 链接:http://www.iss.net/security_center/static/8203.php

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多