漏洞信息详情

Netscreen-Remote VPN客户端IKE包过载远程缓冲区溢出漏洞

  • CNNVD编号:CNNVD-200212-370
  • 危害等级: 中危
  • CVE编号: CVE-2002-2223
  • 漏洞类型: 边界条件错误
  • 发布时间: 2002-09-07
  • 威胁类型: 远程
  • 更新时间: 2007-02-28
  • 厂        商: juniper
  • 漏洞来源:

漏洞简介

Netscreen-Remote VPN客户端可以使用Internet密钥交换协议(IKE)机制进行交换密钥验证。 Netscreen-Remote VPN客户端在处理带有超大负载的IKE包时缺少正确缓冲区边界检查,远程攻击者可以利用这个漏洞对VPN客户端进行缓冲区溢出攻击。 这个漏洞存在于所有Netscreen-Remote VPN客户端如果运行在积极模式(Aggressive mode),并且在IKE KEY交换第一阶段中发生。攻击者可以发送带有超多个负载或者超大负载的非法IKE应答包给Netscreen-Remote VPN客户端,可导致缓冲区溢出,使VPN客户端消耗大量系统CPU资源。 默认情况下,NetScreen-Remote只接收来自信任VPN网关(Main mode)的IKE应答包,但是在积极模式中,非法IKE应答包可以在NetScreen-Remote对VPN网关进行验证前发送,所以攻击者可以以VPN网关的身份对Netscreen-Remote VPN客户端IKE请求进行应答而触发缓冲区溢出,导致拒绝服务攻击。 <*链接:http://www.netscreen.com/support/alerts/9_6_02.htm *>

漏洞公告

临时解决方法: 如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:

* 设置NetScreen-Remote只接收来自信任VPN网关(Main mode)的IKE应答包。 厂商补丁: NetScreen --------- Netscreen声称Netscreen-Remote VPN Client 8.1和Netscreen-Remote Security Client会在2002-09-30推出,届时可以通过如下地址下载:

http://www.netscreen.com/support/updates.html (需要登陆).

参考网址

来源:US-CERT Vulnerability Note: VU#287771 名称: VU#287771 链接:http://www.kb.cert.org/vuls/id/287771 来源: XF 名称: ike-response-bo(9850) 链接:http://xforce.iss.net/xforce/xfdb/9850 来源: BID 名称: 5668 链接:http://www.securityfocus.com/bid/5668 来源: www.netscreen.com 链接:http://www.netscreen.com/support/alerts/9_6_02.htm 来源:NSFOCUS 名称:3476 链接:http://www.nsfocus.net/vulndb/3476

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多