漏洞信息详情

Adobe Reader 5.1 XFDF缓冲区溢出漏洞

  • CNNVD编号:CNNVD-200403-118
  • 危害等级: 高危
  • CVE编号: CVE-2004-0194
  • 漏洞类型: 未知
  • 发布时间: 2004-03-29
  • 威胁类型: 远程
  • 更新时间: 2005-05-13
  • 厂        商: adobe
  • 漏洞来源: David Litchfield※ ...

漏洞简介

Adobe Acrobat Reader用于查看PDF文档,Reader可使XML表单数据格式或XFDF进行扩展。 Adobe Acrobat Reader在处理XFDF文件时不安全调用sprintf,远程攻击者可以利用这个漏洞构建包含此文件类型的恶意链接,诱使用户处理,造成缓冲区溢出。 XFDF文件包含.xfdf扩展,可使用IE浏览器自动下载并打开,另外,不管文件扩展是什么,如果MIME类型设置为\"application/vnd.adobe.xfdf\",文件都会作为XFDF处理。当Adobe Acrobat Reader处理xfdf文件时在使用OutputDebugString输出调试消息时不安全调用sprintf,可造成典型的基于堆栈的缓冲区溢出。进程是否被调试此漏洞代码照样被调用,因此攻击者可以构建包含恶意XFDF文件的WEB链接,或发送EMAIL诱使用户处理,可触发缓冲区溢出,精心构建XFDF数据可能以进程权限执行任意指令。

漏洞公告

厂商补丁: Adobe ----- 目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://www.adobe.com/support/downloads/main.html

参考网址

来源: BID 名称: 9802 链接:http://www.securityfocus.com/bid/9802 来源: www.nextgenss.com 链接:http://www.nextgenss.com/advisories/adobexfdf.txt 来源: XF 名称: acrobatreader-xfdf-bo(15384) 链接:http://xforce.iss.net/xforce/xfdb/15384 来源: OSVDB 名称: 4135 链接:http://www.osvdb.org/4135 来源: BUGTRAQ 名称: 20040303 Abobe Reader 5.1 XFDF Buffer Overflow Vulnerability 链接:http://marc.theaimsgroup.com/?l=bugtraq&m=107842545022724&w=2 来源: FULLDISC 名称: 20040303 Adobe Acrobat Reader XML Forms Data Format Buffer Overflow 链接:http://lists.grok.org.uk/pipermail/full-disclosure/2004-March/018227.html

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多