漏洞信息详情

pcal 多个 缓冲区溢出漏洞

  • CNNVD编号:CNNVD-200501-218
  • 危害等级: 超危
  • CVE编号: CVE-2004-1289
  • 漏洞类型: 缓冲区溢出
  • 发布时间: 2005-01-10
  • 威胁类型: 远程
  • 更新时间: 2005-10-20
  • 厂        商: pcal
  • 漏洞来源: Discovery is credi...

漏洞简介

pcal是一款日历工具程序。 pcal 4.7.1中pcalutil.c的getline函数和readfile.c的get_holiday函数存在缓冲区溢出漏洞。 远程攻击者可使用特别构造当日历文件,利用此漏洞执行任意代码。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接: http://sourceforge.net/projects/pcal/files/

参考网址

来源: XF 名称: pcal-getline-pcalutil-bo(18552) 链接:http://xforce.iss.net/xforce/xfdb/18552 来源: MISC 链接:http://tigger.uic.edu/~jlongs2/holes/pcal.txt

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多