漏洞信息详情

PADL Software 认证绕过漏洞

  • CNNVD编号:CNNVD-200508-239
  • 危害等级: 高危
  • CVE编号: CVE-2005-2641
  • 漏洞类型: 设计错误
  • 发布时间: 2005-08-23
  • 威胁类型: 远程
  • 更新时间: 2005-10-25
  • 厂        商: Padl_software
  • 漏洞来源: Luke HowardJeff Ge...

漏洞简介

pam_ldap模块允许Solaris和Linux服务器及工作站认证LDAP目录,并在目录中更改口令。

pam_ldap口令策略控件中存在漏洞,成功利用这个漏洞允许未经认证的远程攻击者绕过pam_ldap认证机制访问系统。如果pam_ldap客户端试图认证从PasswordPolicyResponseValue中忽略了可选错误值的LDAP服务器的话,认证尝试就总会成功。请注意如果基础LDAP客户端不支持LDAP 3版控件的话,就不会出现这个漏洞。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

ftp://ftp.padl.com/pub/pam_ldap.tgz

参考网址

来源: US-CERT

名称: VU#778916

链接:http://www.kb.cert.org/vuls/id/778916

来源: MISC

链接:https://www.redhat.com/archives/fedora-test-list/2005-August/msg00170.html

来源: issues.rpath.com

链接:https://issues.rpath.com/browse/RPL-680

来源: BID

名称: 14649

链接:http://www.securityfocus.com/bid/14649

来源: BUGTRAQ

名称: 20061005 rPSA-2006-0183-1 nss_ldap

链接:http://www.securityfocus.com/archive/1/archive/1/447859/100/200/threaded

来源: REDHAT

名称: RHSA-2005:767

链接:http://www.redhat.com/support/errata/RHSA-2005-767.html

来源: MANDRIVA

名称: MDKSA-2005:190

链接:http://www.mandriva.com/security/advisories?name=MDKSA-2005:190

来源: SECUNIA

名称: 17270

链接:http://secunia.com/advisories/17270

来源: SECUNIA

名称: 17233

链接:http://secunia.com/advisories/17233

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多