漏洞信息详情

Atutor执行任意PHP函数漏洞

  • CNNVD编号:CNNVD-200511-027
  • 危害等级: 高危
  • CVE编号: CVE-2005-3405
  • 漏洞类型: 输入验证
  • 发布时间: 2005-10-28
  • 威胁类型: 远程
  • 更新时间: 2006-08-23
  • 厂        商: Adaptive_technology_resource_centre
  • 漏洞来源: Andreas Sandblad ...

漏洞简介

ATutor是ATutor团队开发的一套开源的基于Web的学习内容管理系统(LCMS)。该系统包括教学内容管理、论坛、聊天室等模块。

ATutor 1.4.1直到1.5.1-pl1,都允许远程攻击者通过直接向forum.inc.php发出带有修改过的自动增加或减少参数集就可以执行任意的PHP函数,这可能是由于一个eval注入漏洞。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://atutor.ca/view/3/6158/1.html

参考网址

来源: BID

名称: 15221

链接:http://www.securityfocus.com/bid/15221

来源: OSVDB

名称: 20344

链接:http://www.osvdb.org/20344

来源: VUPEN

名称: ADV-2005-2228

链接:http://www.frsirt.com/english/advisories/2005/2228

来源: MISC

链接:http://secunia.com/secunia_research/2005-55/advisory/

来源: SECUNIA

名称: 16915

链接:http://secunia.com/advisories/16915/

来源: BUGTRAQ

名称: 20051027 Secunia Research: ATutor Multiple Vulnerabilities

链接:http://marc.theaimsgroup.com/?l=bugtraq&m=113043022821049&w=2

来源: SECTRACK

名称: 1015165

链接:http://securitytracker.com/id?1015165

来源: SREASON

名称: 123

链接:http://securityreason.com/securityalert/123

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多