漏洞信息详情

PHPBB安全检查绕过漏洞

漏洞简介

phpBB 2是一个论坛软件,使用PHP语言开发的并开放其原始码。

phpBB 2.0.17及更早版本,在启用了register_globals而未调用session_start函数来处理会话时,可让远程攻击者通过将$_SESSION和$HTTP_SESSION_VARS变量设置为字符串而非数组来绕过安全性检查,这会导致array_merge函数调用失败。

漏洞公告

参考网址

来源: BID

名称: 15243

链接:http://www.securityfocus.com/bid/15243

来源: SECTRACK

名称: 1015121

链接:http://securitytracker.com/id?1015121

来源: BUGTRAQ

名称: 20051031 Advisory 17/2005: phpBB Multiple Vulnerabilities

链接:http://marc.theaimsgroup.com/?l=bugtraq&m=113081113317600&w=2

来源: MISC

链接:http://www.hardened-php.net/advisory_172005.75.html

来源: SECUNIA

名称: 17366

链接:http://secunia.com/advisories/17366

来源: BUGTRAQ

名称: 20051031 Advisory 17/2005: phpBB Multiple Vulnerabilities

链接:http://marc.theaimsgroup.com/?l=bugtraq&m=113081113317600&w=2

来源: OSVDB

名称: 20413

链接:http://www.osvdb.org/20413

来源: DEBIAN

名称: DSA-925

链接:http://www.debian.org/security/2005/dsa-925

来源: SREASON

名称: 130

链接:http://securityreason.com/securityalert/130

来源: SECUNIA

名称: 18098

链接:http://secunia.com/advisories/18098

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多