漏洞信息详情

EZDatabase多个输入验证漏洞

漏洞简介

EZDatabase是用PHP和MySQL编写的在线数据库程序。

EZDatabase中存在多个输入验证错误,如下:

1. 没有正确验证对"p"参数的输入,可能导致包含本地资源的任意文件;

2. 没有正确验证对"db_id"参数的输入,可能导致通过注入任意SQL代码来操控SQL查询;

3. 没有正确验证对"cat_id"参数的输入,可能导致泄漏完整的安装路径。

漏洞公告

参考网址

来源: BID

名称: 15908

链接:http://www.securityfocus.com/bid/15908

来源: OSVDB

名称: 21797

链接:http://www.osvdb.org/21797

来源: MISC

链接:http://pridels0.blogspot.com/2005/12/ezdatabase-vuln.html

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多