漏洞信息详情

Libmikmod XCOM处理器远程堆溢出漏洞

  • CNNVD编号:CNNVD-200607-235
  • 危害等级: 高危
  • CVE编号: CVE-2006-3668
  • 漏洞类型: 缓冲区溢出
  • 发布时间: 2006-07-18
  • 威胁类型: 远程
  • 更新时间: 2006-08-28
  • 厂        商: dynamic_universal_music_bibliotheque
  • 漏洞来源: Luigi Auriemma alu...

漏洞简介

libmikmod是Mikmod所使用的函数库,主要用于播放各种类型的音频模块。

libmikmod在处理XCOM对象时存在堆溢出漏洞,远程攻击者可能利用此漏洞在客户机器上执行任意指令。

在处理XCOM块时libmikmod读取了用于指定标注大小的32位数字,然后分配等于该大小加1的内存,以容纳标注末尾可能的空字节。因此如果攻击者使用了0xffffffff值(0xffffffff + 1 = 0)的话,函数库就可能分配0字节的内存。然后在试图读取大小值所指定的内存数量时,就会导致堆溢出。

loaders/load_gt2.c中的漏洞代码:

GT_CHUNK *loadChunk(void)

...

if (!memcmp(new_chunk, \"XCOM\", 4)) {

new_chunk->xcom.chunk_size = _mm_read_M_ULONG(modreader);

new_chunk->xcom.comment_len = _mm_read_M_ULONG(modreader);

new_chunk->xcom.comment = MikMod_malloc(new_chunk->xcom.comment_len + 1);

_mm_read_UBYTES(new_chunk->xcom.comment, new_chunk->xcom.comment_len, modreader);

return new_chunk;

}

...

漏洞公告

目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://www.mikmod.org/

参考网址

来源: BID

名称: 19025

链接:http://www.securityfocus.com/bid/19025

来源: GENTOO

名称: GLSA-200608-14

链接:http://www.gentoo.org/security/en/glsa/glsa-200608-14.xml

来源: VUPEN

名称: ADV-2006-2835

链接:http://www.frsirt.com/english/advisories/2006/2835

来源: DEBIAN

名称: DSA-1123

链接:http://www.debian.org/security/2006/dsa-1123

来源: SECUNIA

名称: 21416

链接:http://secunia.com/advisories/21416

来源: SECUNIA

名称: 21184

链接:http://secunia.com/advisories/21184

来源: SECUNIA

名称: 21092

链接:http://secunia.com/advisories/21092

来源: MISC

链接:http://aluigi.altervista.org/adv/dumbit-adv.txt

来源: XF

名称: dumb-itreadenvelope-bo(27789)

链接:http://xforce.iss.net/xforce/xfdb/27789

来源: SREASON

名称: 1240

链接:http://securityreason.com/securityalert/1240

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多