漏洞信息详情

Linux-PAM pam_unix.so绕过认证漏洞

漏洞简介

可插拔认证模块(PAM)是用于认证用户的机制,使用在多种Linux版本上。

Linux-PAM的modules/pam_unix/support.c文件中_unix_verify_password()函数在验证用户口令时存在漏洞,远程攻击者可能利用此漏洞获取非授权访问。如果口令文件中的哈希为"!!"或类似的话,用户就可以以任意口令登录。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

http://www.kernel.org/pub/linux/libs/pam/pre/library/Linux-PAM-0.99.7.1.tar.gz

参考网址

来源: MLIST

名称: [pam-list] 20070123 Linux-PAM 0.99.7.1 released

链接:https://www.redhat.com/archives/pam-list/2007-January/msg00017.html

来源: MLIST

名称: [fedora-devel-list] 20070122 Re: rawhide report: 20070120 changes

链接:http://www.redhat.com/archives/fedora-devel-list/2007-January/msg01277.html

来源: MLIST

名称: [fedora-devel-list] 20070122 Re: rawhide report: 20070120 changes

链接:http://www.redhat.com/archives/fedora-devel-list/2007-January/msg01271.html

来源: OSVDB

名称: 32017

链接:http://osvdb.org/32017

来源: XF

名称: linuxpam-pamunix-security-bypass(31739)

链接:http://xforce.iss.net/xforce/xfdb/31739

来源: BID

名称: 22204

链接:http://www.securityfocus.com/bid/22204

来源: SUSE

名称: SUSE-SR:2007:003

链接:http://www.novell.com/linux/security/advisories/2007_3_sr.html

来源: VUPEN

名称: ADV-2007-0323

链接:http://www.frsirt.com/english/advisories/2007/0323

来源: SECUNIA

名称: 23858

链接:http://secunia.com/advisories/23858

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多