漏洞信息详情

FreePBX upgrade.php远程文件包含漏洞

  • CNNVD编号:CNNVD-200703-143
  • 危害等级: 高危
  • CVE编号: CVE-2006-7107
  • 漏洞类型: 输入验证
  • 发布时间: 2006-10-30
  • 威胁类型: 远程
  • 更新时间: 2007-03-07
  • 厂        商: coalescent_systems
  • 漏洞来源:

漏洞简介

FreePBX(前称Asterisk Management Portal)是FreePBX项目的一套通过GUI(基于网页的图形化接口)配置Asterisk(IP电话系统)的工具。 FreePBX在处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上以Web进程权限执行任意命令。 FreePBX的upgrade.php文件没有正确验证对amp_conf参数的输入,允许攻击者通过包含本地或外部任意资源导致执行任意PHP代码。漏洞相关的代码如下: require_once($amp_conf[\"AMPWEBROOT\"] . \"/admin/functions.inc.php\");

漏洞公告

目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://www.freepbx.org

参考网址

来源: XF 名称: freepbx-upgrade-file-include(29879) 链接:http://xforce.iss.net/xforce/xfdb/29879 来源: BID 名称: 20785 链接:http://www.securityfocus.com/bid/20785 来源: MILW0RM 名称: 2665 链接:http://www.milw0rm.com/exploits/2665

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多