漏洞信息详情

Courier-IMAP XMAILDIR变量远程Shell命令注入漏洞

  • CNNVD编号:CNNVD-200704-426
  • 危害等级: 超危
  • CVE编号: CVE-2007-2173
  • 漏洞类型: 输入验证
  • 发布时间: 2007-04-24
  • 威胁类型: 远程
  • 更新时间: 2007-04-24
  • 厂        商: gentoo
  • 漏洞来源: CJ Kucera

漏洞简介

Courier-IMAP是Courier邮件系统中的IMAP服务程序。

Courier-IMAP对变量数据的过滤上存在漏洞,远程攻击者可能利用此漏洞在服务器上执行任意指令。

Courier-IMAP的/usr/lib/courier-imap/courier-imapd.indirect和/usr/lib/courier-imap/courier-pop3d.indirect文件没有充分检查过滤${XMAILDIR}变量,可能导致远程命令执行。假设系统中存在名为user &name的用户(\" &\"符号在邮件地址中是有效的),用户的maildir扩展为/var/spool/mail/domain.com/user &name。当该用户通过IMAP或POP登录时日志中会记录以下内容:

pop3d: /usr/lib/courier-imap/courier-pop3d.indirect: line 3: name: command not

found

pop3d: chdir /var/spool/mail/domain.com/user: No such file or directory

可见\" &\"符号能导致进程试图运行name命令。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.courier-mta.org/imap

参考网址

来源: SECUNIA

名称: 24963

链接:http://secunia.com/advisories/24963

来源: GENTOO

名称: GLSA-200704-18

链接:http://security.gentoo.org/glsa/glsa-200704-18.xml

来源: OSVDB

名称: 35274

链接:http://osvdb.org/35274

来源: bugs.gentoo.org

链接:http://bugs.gentoo.org/show_bug.cgi?id=168196

来源: XF

名称: gentoo-courier-imap-command-execution(33805)

链接:http://xforce.iss.net/xforce/xfdb/33805

来源: BID

名称: 23589

链接:http://www.securityfocus.com/bid/23589

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多