漏洞信息详情

Phorum admin.php输入验证漏洞

漏洞简介

Phorum是一款基于PHP的WEB论坛程序,可在Linux和Unix操作系统下使用,也可在Microsoft Windows操作系统下使用。

Phorum的admin.php文件中module变量可能导致泄露路径。

在编辑banlist时使用了GET方式,漏洞代码位于include/admin/banlist.php的47行:

--------------------------------------------------

if(isset($_GET["curr"])){

if(isset($_GET["delete"])){

phorum_db_del_banitem($_GET['curr']);

echo "Ban Item Deleted ";

} else {

$curr = $_GET["curr"];

}

}

--------------------------------------------------

这可能允许用户轻易的删除banlist项。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

http://www.phorum.org/downloads/phorum-5.1.22.tar.gz

参考网址

来源: MISC

链接:http://www.waraxe.us/advisory-49.html

来源: BID

名称: 23616

链接:http://www.securityfocus.com/bid/23616

来源: BUGTRAQ

名称: 20070419 [waraxe-2007-SA#049] - Multiple vulnerabilities in Phorum 5.1.20

链接:http://www.securityfocus.com/archive/1/archive/1/466286/100/0/threaded

来源: VUPEN

名称: ADV-2007-1479

链接:http://www.frsirt.com/english/advisories/2007/1479

来源: SECUNIA

名称: 24932

链接:http://secunia.com/advisories/24932

来源: SECTRACK

名称: 1017936

链接:http://www.securitytracker.com/id?1017936

来源: www.phorum.org

链接:http://www.phorum.org/story.php?76

来源: OSVDB

名称: 35060

链接:http://osvdb.org/35060

来源: SREASON

名称: 2617

链接:http://securityreason.com/securityalert/2617

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多