漏洞信息详情

TCExam $_SERVER[] 'tce_config.php' 跨站脚本攻击漏洞

  • CNNVD编号:CNNVD-200705-003
  • 危害等级: 中危
  • CVE编号: CVE-2007-2431
  • 漏洞类型: 跨站脚本
  • 发布时间: 2007-05-01
  • 威胁类型: 远程
  • 更新时间: 2007-05-04
  • 厂        商: tecnick.com
  • 漏洞来源: rgod is credited w...

漏洞简介

TCExam 的shared/config/tce_config.php中存在动态变量评估漏洞。远程攻击者可以通过修改重要的变量,比如$_SERVER,来执行跨站脚本攻击和可能其他攻击,比如借助_SERVER[SCRIPT_NAME]参数注入web脚本。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

http://downloads.sourceforge.net/tcexam/tcexam_4_1_000.zip?modtime=1177956448&big_mirror=0

参考网址

来源: sourceforge.net

链接:http://sourceforge.net/forum/forum.php?forum_id=690912

来源: MILW0RM

名称: 3816

链接:http://www.milw0rm.com/exploits/3816

来源: VIM

名称: 20070501 TCExam - 'XSS' is dynamic variable evaluation; vendor patch

链接:http://www.attrition.org/pipermail/vim/2007-May/001572.html

来源: XF

名称: tcexam-server-xss(33957)

链接:http://xforce.iss.net/xforce/xfdb/33957

来源: BID

名称: 23704

链接:http://www.securityfocus.com/bid/23704

来源: SECUNIA

名称: 25008

链接:http://secunia.com/advisories/25008

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多