漏洞信息详情

QEMU code_gen_buffer缓冲区本地溢出漏洞

  • CNNVD编号:CNNVD-200712-026
  • 危害等级: 高危
  • CVE编号: CVE-2007-6227
  • 漏洞类型: 缓冲区溢出
  • 发布时间: 2007-11-16
  • 威胁类型: 本地
  • 更新时间: 2008-12-20
  • 厂        商: qemu
  • 漏洞来源: TeLeMan geleman@gm...

漏洞简介

QEMU(又名Quick Emulator)是法国程序员法布里斯-贝拉(Fabrice Bellard)所研发的一套模拟处理器软件。该软件具有速度快、跨平台等特点。

QEMU在处理畸形数据数据时存在漏洞,本地攻击者可能利用此漏洞导致系统崩溃。

本地攻击者可以通过发送超长数据溢出QEMU的code_gen_buffer缓冲区,覆盖TranslationBlock缓冲区,导致拒绝服务的情况。

漏洞公告

目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://fabrice.bellard.free.fr/qemu/

参考网址

来源: BID

名称: 26666

链接:http://www.securityfocus.com/bid/26666

来源: BUGTRAQ

名称: 20071130 QEMU code_gen_buffer overflow POC

链接:http://www.securityfocus.com/archive/1/archive/1/484429/100/0/threaded

来源: MANDRIVA

名称: MDVSA-2008:162

链接:http://www.mandriva.com/security/advisories?name=MDVSA-2008:162

来源: SECUNIA

名称: 29129

链接:http://secunia.com/advisories/29129

来源: XF

名称: qemu-translationblock-dos(38806)

链接:http://xforce.iss.net/xforce/xfdb/38806

来源:NSFOCUS 名称:11241 链接:http://www.nsfocus.net/vulndb/11241

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多