漏洞信息详情

Firebird ISC_PASSWORD init脚本环境变量非授权访问漏洞

  • CNNVD编号:CNNVD-200805-092
  • 危害等级: 中危
  • CVE编号: CVE-2008-1880
  • 漏洞类型: 信任管理
  • 发布时间: 2008-05-12
  • 威胁类型: 远程
  • 更新时间: 2008-09-05
  • 厂        商: gentoo
  • 漏洞来源: Viesturs

漏洞简介

Firebird是一款提供多个ANSI SQL-92功能的关系型数据库,可运行在Linux、Windows和各种Unix平台下

Gentoo的init脚本(/etc/conf.d/firebird)在启动Firebird时默认会设置ISC_PASSWORD环境变量,当以SYSDBA用户身份连接的客户端没有提供口令时会使用这个变量,这允许远程攻击者无需提供凭据便认证为SYSDBA用户,访问除用户和口令数据库之外的整个数据库。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

http://security.gentoo.org/glsa/glsa-200805-06.xml

参考网址

来源: XF

名称: firebird-sysdba-unath-access(42299)

链接:http://xforce.iss.net/xforce/xfdb/42299

来源: BID

名称: 29123

链接:http://www.securityfocus.com/bid/29123

来源: GENTOO

名称: GLSA-200805-06

链接:http://security.gentoo.org/glsa/glsa-200805-06.xml

来源: SECUNIA

名称: 30162

链接:http://secunia.com/advisories/30162

来源: bugs.gentoo.org

链接:http://bugs.gentoo.org/show_bug.cgi?id=216158

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多