漏洞信息详情

phpAdmin setup.php 跨站脚本攻击漏洞

  • CNNVD编号:CNNVD-200808-045
  • 危害等级: 低危
  • CVE编号: CVE-2008-3457
  • 漏洞类型: 跨站脚本
  • 发布时间: 2008-07-29
  • 威胁类型: 远程
  • 更新时间: 2009-03-07
  • 厂        商: phpmyadmin
  • 漏洞来源: Aung Khant

漏洞简介

phpMyAdmin是用PHP编写的工具,用于通过WEB管理MySQL。

phpMyAdmin 2.11.8之前版本的setup.php文件存在跨站脚本攻击漏洞。攻击者通过构造setup参数,可以注入任意web脚本或者html。注:形成攻击的前提是攻击者必须能够修改config/config.inc.php文件。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接: http: http://www.phpmyadmin.net/home_page/downloads.php

参考网址

来源: FEDORA

名称: FEDORA-2008-6868

链接:https://www.redhat.com/archives/fedora-package-announce/2008-July/msg01316.html

来源: FEDORA

名称: FEDORA-2008-6810

链接:https://www.redhat.com/archives/fedora-package-announce/2008-July/msg01239.html

来源: MISC

链接:http://yehg.net/lab/pr0js/advisories/XSS_inPhpMyAdmin2.11.7.pdf

来源: XF

名称: phpmyadmin-setup-configinc-xss(44052)

链接:http://xforce.iss.net/xforce/xfdb/44052

来源: BID

名称: 30420

链接:http://www.securityfocus.com/bid/30420

来源: www.phpmyadmin.net

链接:http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2008-6

来源: MANDRIVA

名称: MDVSA-2008:202

链接:http://www.mandriva.com/security/advisories?name=MDVSA-2008:202

来源: VUPEN

名称: ADV-2008-2226

链接:http://www.frsirt.com/english/advisories/2008/2226/references

来源: DEBIAN

名称: DSA-1641

链接:http://www.debian.org/security/2008/dsa-1641

来源: SECUNIA

名称: 32834

链接:http://secunia.com/advisories/32834

来源: SECUNIA

名称: 31312

链接:http://secunia.com/advisories/31312

来源: SECUNIA

名称: 31263

链接:http://secunia.com/advisories/31263

来源: SUSE

名称: SUSE-SR:2008:026

链接:http://lists.opensuse.org/opensuse-security-announce/2008-11/msg00002.html

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多