漏洞信息详情

phpMyAdmin 'pmd_pdf.php'模块跨站脚本漏洞

  • CNNVD编号:CNNVD-200810-484
  • 危害等级: 低危
  • CVE编号: CVE-2008-4775
  • 漏洞类型: 跨站脚本
  • 发布时间: 2008-10-28
  • 威胁类型: 远程
  • 更新时间: 2009-04-18
  • 厂        商: phpmyadmin
  • 漏洞来源: Hadi Kiamarsi※ had...

漏洞简介

phpMyAdmin是用PHP编写的工具,用于通过WEB管理MySQL。

phpMyAdmin的pmd_pdf.php模块没有正确地验证对db参数的输入便返回给了用户,远程攻击者可以通过提交恶意请求执行跨站脚本攻击,导致在用户浏览器会话中执行任意HTML和脚本代码。成功攻击要求打开了register_globals且拥有有效的用户凭据。

漏洞公告

目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://www.phpmyadmin.net/

参考网址

来源: FEDORA

名称: FEDORA-2008-9336

链接:https://www.redhat.com/archives/fedora-package-announce/2008-October/msg00925.html

来源: FEDORA

名称: FEDORA-2008-9316

链接:https://www.redhat.com/archives/fedora-package-announce/2008-October/msg00908.html

来源: XF

名称: phpmyadmin-pmdpdf-xss(46136)

链接:http://xforce.iss.net/xforce/xfdb/46136

来源: BID

名称: 31928

链接:http://www.securityfocus.com/bid/31928

来源: BUGTRAQ

名称: 20081027 XSS in phpMyadmin

链接:http://www.securityfocus.com/archive/1/archive/1/497815/100/0/threaded

来源: VUPEN

名称: ADV-2008-2943

链接:http://www.frsirt.com/english/advisories/2008/2943

来源: SREASON

名称: 4516

链接:http://securityreason.com/securityalert/4516

来源: GENTOO

名称: GLSA-200903-32

链接:http://security.gentoo.org/glsa/glsa-200903-32.xml

来源: SECUNIA

名称: 32482

链接:http://secunia.com/advisories/32482

来源: SECUNIA

名称: 32449

链接:http://secunia.com/advisories/32449

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多