漏洞信息详情

GpsDrive 'geo-code'任意文件重写漏洞

  • CNNVD编号:CNNVD-200811-104
  • 危害等级: 中危
  • CVE编号: CVE-2008-4959
  • 漏洞类型: 后置链接
  • 发布时间: 2008-11-05
  • 威胁类型: 本地
  • 更新时间: 2009-03-06
  • 厂        商: gpsdrive
  • 漏洞来源: Dmitry E. Oboukhov

漏洞简介

GpsDrive是一个汽车(车,船,飞机)导航系统。

Gpsdrive 2.10~pre4版本中的geo-code允许本地用户借助一个对(1)/tmp/geo.google,(2)/tmp/geo.yahoo,(3)/tmp/geo.coords和(4) /tmp/geo#####.coords临时文件的symlink攻击,重写任意文件。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

Debian gpsdrive-scripts 2.10~pre4-6

http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=14;filename=gpsdrive- temp.patch;att=1;bug=496436

参考网址

来源: FEDORA

名称: FEDORA-2009-1366

链接:https://www.redhat.com/archives/fedora-package-announce/2009-February/msg00187.html

来源:bugs.gentoo.org

链接:https://bugs.gentoo.org/show_bug.cgi?id=235770

来源: XF

名称: gpsdrive-geocode-symlink(44759)

链接:http://xforce.iss.net/xforce/xfdb/44759

来源: BID

名称: 30905

链接:http://www.securityfocus.com/bid/30905

来源: MLIST

名称: [oss-security] 20081030 CVE requests: tempfile issues for aview, mgetty, openoffice, crossfire

链接:http://www.openwall.com/lists/oss-security/2008/10/30/2

来源: MISC

链接:http://uvw.ru/report.lenny.txt

来源: SECUNIA

名称: 33825

链接:http://secunia.com/advisories/33825

来源: SECUNIA

名称: 31694

链接:http://secunia.com/advisories/31694

来源:dev.gentoo.org

链接:http://dev.gentoo.org/~rbu/security/debiantemp/gpsdrive-scripts

来源: bugs.debian.org

链接:http://bugs.debian.org/496436

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多