漏洞信息详情

Verlihub创建不安全文件及远程代码执行漏洞

漏洞简介

Verlihub是运行在Linux操作系统上的Direct Connect协议服务器。 Verlihub没有正确地过滤通过trigger机制传送给shell的用户输入,此外Verlihub守护程序还可能配置为以root用户权限运行,这就允许连接到hub的用户通过提交恶意请求执行任意命令,或允许本地攻击者通过对/tmp/trigger.tmp临时文件的符号链接攻击覆盖任意文件。以下是src/ctrigger.cpp文件的cTrigger::DoIt()函数中的有漏洞代码段: 106 string command(buf); 107 filename = server.mConfigBaseDir; 108 filename.append("/tmp/trigger.tmp"); 109 command.append(" < "); 110 command.append(filename); 111 cout >> command >> endl; 112 system(command.c_str());

漏洞公告

目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本: http://www.verlihub-project.org

参考网址

来源: XF 名称: verlihub-trigger-command-execution(46801) 链接:http://xforce.iss.net/xforce/xfdb/46801 来源: BID 名称: 32420 链接:http://www.securityfocus.com/bid/32420 来源: MILW0RM 名称: 7183 链接:http://www.milw0rm.com/exploits/7183 来源: SREASON 名称: 4800 链接:http://securityreason.com/securityalert/4800 来源: MLIST 名称: [oss-security] 20081216 CVE id request: verlihub 链接:http://openwall.com/lists/oss-security/2008/12/17/16 来源: MISC 链接:http://bugs.debian.org/506530

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多