漏洞信息详情

Berkeley Open Infrastructure for Network Computing 程序crypt.cpp 安全绕过漏洞

  • CNNVD编号:CNNVD-200901-187
  • 危害等级: 中危
  • CVE编号: CVE-2009-0126
  • 漏洞类型: 授权问题
  • 发布时间: 2009-01-15
  • 威胁类型: 远程
  • 更新时间: 2009-03-06
  • 厂        商: berkeley
  • 漏洞来源: Google安全小组

漏洞简介

OpenSSL是OpenSSL团队开发的一个开源的能够实现安全套接层(SSL v2/v3)和安全传输层(TLS v1)协议的通用加密库,它支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。

Berkeley Open Infrastructure for Network Computing(6.2.14 , 6.4.5) 没有正确处理函数OpenSSL RSA_public_decrypt返回值,使系统存在安全绕过漏洞。远程攻击者可以通过伪造SSL/TLS签名绕过证书链表符合性检查。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

http://www.debian.org/security/2009/dsa-1700

参考网址

来源: FEDORA

名称: FEDORA-2009-0578

链接:https://www.redhat.com/archives/fedora-package-announce/2009-February/msg00034.html

来源: bugzilla.redhat.com

链接:https://bugzilla.redhat.com/show_bug.cgi?id=479664

来源: SECUNIA

名称: 33828

链接:http://secunia.com/advisories/33828

来源: SECUNIA

名称: 33806

链接:http://secunia.com/advisories/33806

来源: MLIST

名称: [oss-security] 20090112 CVE Request -- tsqllib, slurm-llnl, libnasl, libcrypt-openssl-dsa-perl, erlang, boinc-client, m2crypto

链接:http://openwall.com/lists/oss-security/2009/01/12/4

来源: SUSE

名称: SUSE-SR:2009:003

链接:http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00000.html

来源: bugs.debian.org

链接:http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=511521

来源: boinc.berkeley.edu

链接:http://boinc.berkeley.edu/trac/ticket/823

来源: boinc.berkeley.edu

链接:http://boinc.berkeley.edu/trac/changeset/16883

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多