漏洞信息详情

FreeBSD telnetd守护程序远程代码执行漏洞

  • CNNVD编号:CNNVD-200902-468
  • 危害等级: 高危
  • CVE编号: CVE-2009-0641
  • 漏洞类型: 配置错误
  • 发布时间: 2009-02-20
  • 威胁类型: 远程
  • 更新时间: 2009-02-21
  • 厂        商: freebsd
  • 漏洞来源: Kingcope kingcop...

漏洞简介

FreeBSD就是一种运行在Intel平台上、可以自由使用的开放源码Unix类系统。

telnet协议允许传送telnet通讯中的环境变量并分配给tcp连接的另一端。FreeBSD的telnet守护程序在执行/bin/login之前没有检查LD_* (如LD_PRELOAD)环境变量,因此攻击者可以在传送的环境变量中包含LD_PRELOAD标识和文件系统上带有恶意代码的预编译库值。在以用户id和组id 0(root)执行/bin/login时,就会通过telnet环境定义预加载远程连接所设置的库并执行。

能够向目标系统放置特制文件(通过合法的登录到系统或利用系统上的其他服务)可以以运行telnet守护程序(通常为root)用户的权限执行任意代码。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

FreeBSD已经为此发布了一个安全公告(FreeBSD-SA-09:05)以及相应补丁:

FreeBSD-SA-09:05:telnetd code execution vulnerability

ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-09:05.telnetd.asc

补丁下载:

1) 将有漏洞的系统升级到7-STABLE,或修改日期之后的RELENG_7_1或RELENG_7_0安全版本。

2) 为当前系统打补丁:

以下补丁确认可应用于FreeBSD 7.0和7.1系统。

a) 从以下位置下载相关补丁,并使用PGP工具验证附带的PGP签名。

# fetch http://security.FreeBSD.org/patches/SA-09:05/telnetd.patch

# fetch http://security.FreeBSD.org/patches/SA-09:05/telnetd.patch.asc

b) 以root执行以下命令:

# cd /usr/src

# patch < /path/to/patch

# cd /usr/src/lib/bind

# make obj && make depend && make && make install

# cd /usr/src/usr.sbin/named

# make obj && make depend && make && make install

# /etc/rc.d/named restart

c) 安装并使用FreeBSD移植集的修复版本BIND。

参考网址

来源: FREEBSD

名称: FreeBSD-SA-09:05

链接:http://security.freebsd.org/advisories/FreeBSD-SA-09:05.telnetd.asc

来源: XF

名称: freebsd-telnet-ldpreload-code-execution(48780)

链接:http://xforce.iss.net/xforce/xfdb/48780

来源: BID

名称: 33777

链接:http://www.securityfocus.com/bid/33777

来源: MILW0RM

名称: 8055

链接:http://www.milw0rm.com/exploits/8055

来源: FULLDISC

名称: 20090214 FreeBSD zeroday

链接:http://lists.grok.org.uk/pipermail/full-disclosure/2009-February/067954.html

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多