漏洞信息详情

Linux kernel ’fs/ext4/super.c’输入验证错误漏洞

  • CNNVD编号:CNNVD-200902-669
  • 危害等级: 低危
  • CVE编号: CVE-2009-0748
  • 漏洞类型: 输入验证
  • 发布时间: 2009-02-27
  • 威胁类型: 本地
  • 更新时间: 2009-04-16
  • 厂        商: linux
  • 漏洞来源:

漏洞简介

Linux是一款开放源码的Unix风格(Unix alike)的操作系统(OS),在原代码级上兼容绝大部分Unix标准(指的是IEEE POSIX,System V,BSD),是一个支持多用户, 多进程,多线程,实时性较好的功能强大而稳定的操作系统。

Linux kernel 2.6.27.19版本之前的版本2.6.27以及2.6.28.7之前的版本2.6.28中的fs/ext4/super.c的ext4_fill_super函数没有校验超级街区设置,这会允许本地用户通过尝试固定一个特制的ext4文件系统,以造成拒绝服务(空指针指令和OOPS)。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.32.1.tar.bz2

参考网址

来源: VUPEN

名称: ADV-2009-0509

链接:http://www.vupen.com/english/advisories/2009/0509

来源: UBUNTU

名称: USN-751-1

链接:http://www.ubuntu.com/usn/usn-751-1

来源: DEBIAN

名称: DSA-1749

链接:http://www.debian.org/security/2009/dsa-1749

来源: SECUNIA

名称: 34394

链接:http://secunia.com/advisories/34394

来源: kernel.org

链接:http://kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.28.7

来源: kernel.org

链接:http://kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.27.19

来源: git.kernel.org

链接:http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=4ec110281379826c5cf6ed14735e47027c3c5765

来源: bugzilla.kernel.org

链接:http://bugzilla.kernel.org/show_bug.cgi?id=12371

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多