漏洞信息详情

OpenBSD bgpd守护程序远程拒绝服务漏洞

  • CNNVD编号:CNNVD-200903-066
  • 危害等级: 中危
  • CVE编号: CVE-2009-0780
  • 漏洞类型: 设计错误
  • 发布时间: 2009-02-18
  • 威胁类型: 远程
  • 更新时间: 2009-03-04
  • 厂        商: Openbsd
  • 漏洞来源: OpenBSD

漏洞简介

OpenBSD是一款开放源代码Unix类操作系统。

OpenBSD的usr.sbin/bgpd/rde_attr.c文件中的aspath_prepend()函数在将其自己的AS附加到超长AS路径时存在错误,如果远程攻击者广播了超长的AS路径就会导致bgpd进程崩溃。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

ftp://ftp.openbsd.org/pub/OpenBSD/patches/4.3/common/010_bgpd.patch

参考网址

来源: OPENBSD

名称: [4.4] 010: RELIABILITY FIX: February 18, 2009

链接: http://openbsd.org/errata44.html#010_bgpd

来源: OPENBSD

名称: [4.3] 010: RELIABILITY FIX: February 18, 2009

链接: http://openbsd.org/errata43.html#010_bgpd

来源: XF

名称: openbsd-aspathprepend-dos(48812)

链接: http://xforce.iss.net/xforce/xfdb/48812

来源: SECTRACK

名称: 1021736

链接: http://www.securitytracker.com/id?1021736

来源: BID

名称: 33828

链接: http://www.securityfocus.com/bid/33828

来源: SECUNIA

名称: 33975

链接: http://secunia.com/advisories/33975

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多