漏洞信息详情

Drupal 'Printer, e-mail and PDF versions' Module HTML注入漏洞

  • CNNVD编号:CNNVD-200905-342
  • 危害等级: 低危
  • CVE编号: CVE-2009-1823
  • 漏洞类型: 跨站脚本
  • 发布时间: 2009-05-29
  • 威胁类型: 远程
  • 更新时间: 2009-06-01
  • 厂        商: drupal
  • 漏洞来源: Daniel F. Kudwien

漏洞简介

Drupal Print (又称Printer, e-mail and PDF versions) module 5.x-4.7版本之前的5.x版本以及6.x-1.7版本之前的6.x版本中存在跨站脚本攻击漏洞。远程攻击者可以通过修改一个Content-Type META元件之前的文件抬头来包含一个特制的UTF-8字节序列,注入任意web脚本或HTML,且该字节序列会被IE6版本或7版本当作UTF-7字节序列处理。

漏洞公告

目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:

Drupal Print 6.x-1.10.tar.gz

http://ftp.drupal.org/files/projects/print-6.x-1.10.tar.gz

参考网址

来源: VUPEN

名称: ADV-2009-1320

链接:http://www.vupen.com/english/advisories/2009/1320

来源: drupal.org

链接:http://drupal.org/node/461674

来源: XF

名称: printeremailpdf-utf7-xss(50523)

链接:http://xforce.iss.net/xforce/xfdb/50523

来源: BID

名称: 34954

链接:http://www.securityfocus.com/bid/34954

来源: SECUNIA

名称: 35040

链接:http://secunia.com/advisories/35040

来源: OSVDB

名称: 54427

链接:http://osvdb.org/54427

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多