漏洞信息详情

Openswan安全绕过漏洞

  • CNNVD编号:CNNVD-201105-219
  • 危害等级: 低危
  • CVE编号: CVE-2011-2147
  • 漏洞类型: 权限许可和访问控制
  • 发布时间: 2011-05-23
  • 威胁类型: 本地
  • 更新时间: 2011-05-23
  • 厂        商: openswan
  • 漏洞来源:

漏洞简介

Xelerance Openswan是加拿大Xelerance公司的一个基于FreeS/WAN项目的用于Linux系统下的IPSEC实现,它主要用于保证数据传输中的安全性、完整性等问题。

Openswan 2.2.x版本不能正确限制/var/run/starter.pid(与IPsec starter中的starter.c有关)和/var/lock/subsys/ipsec的权限。本地用户可以通过向文件写入PID,终止任意进程,或者通过向文件写入任意数据,绕过磁盘分配。

漏洞公告

目前厂商还没有提供此漏洞的相关补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://www.openswan.org/

参考网址

来源: MLIST

名称: [debian-security] 20110510 Re: World writable pid and lock files.

链接:http://lists.debian.org/debian-security/2011/05/msg00018.html

来源: MLIST

名称: [debian-security] 20110510 Re: World writable pid and lock files.

链接:http://lists.debian.org/debian-security/2011/05/msg00013.html

来源: MLIST

名称: [debian-security] 20110510 World writable pid and lock files.

链接:http://lists.debian.org/debian-security/2011/05/msg00012.html

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多