漏洞信息详情

phpMyAdmin ‘js/replication.js’ 跨站脚本漏洞

  • CNNVD编号:CNNVD-201205-065
  • 危害等级: 中危
  • CVE编号: CVE-2012-1190
  • 漏洞类型: 跨站脚本
  • 发布时间: 2012-05-04
  • 威胁类型: 远程
  • 更新时间: 2012-05-04
  • 厂        商: phpmyadmin
  • 漏洞来源:

漏洞简介

phpMyAdmin是phpMyAdmin团队开发的一套免费的、基于Web的MySQL数据库管理工具。该工具能够创建和删除数据库,创建、删除、修改数据库表,执行SQL脚本命令等。

phpMyAdmin 3.4.10.1之前的3.4.x版本中的js/replication.js中的replication-setup函数中存在跨站脚本漏洞。远程攻击者可利用该漏洞借助特制数据库名称注入任意web脚本或者HTML。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://www.phpmyadmin.net/home_page/security/PMASA-2012-1.php

参考网址

来源: github.com

链接:https://github.com/phpmyadmin/phpmyadmin/commit/86073d532aed656550cb731aa5b4288b126ae7a6

来源: www.phpmyadmin.net

链接:http://www.phpmyadmin.net/home_page/security/PMASA-2012-1.php

漏洞信息快速查询

相关漏洞

更多