漏洞信息详情

Ruby on Rails SQL注入漏洞

  • CNNVD编号:CNNVD-201206-025
  • 危害等级: 中危
  • CVE编号: CVE-2012-2660
  • 漏洞类型: 权限许可和访问控制问题
  • 发布时间: 2012-05-31
  • 威胁类型: 远程
  • 更新时间: 2019-08-09
  • 厂        商: rubyonrails
  • 漏洞来源: Ben Murphy

漏洞简介

Ruby on Rails简称RoR或Rails,是一个更符合实际需要而且更高效的Web开发框架。

Rails on Ruby中的actionpack/lib/action_dispatch/http/request.rb中存在SQL注入漏洞。攻击者可利用该漏洞操控应用程序,访问或者修改数据,或在底层数据库中利用该漏洞。该漏洞在以下版本中修复:Rails on Ruby 3.2.4版本,3.1.5版本与3.0.13版本。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://rubyonrails.org/

参考网址

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00016.html

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00014.html

来源:MLIST

链接:https://groups.google.com/group/rubyonrails-security/msg/d890f8d58b5fbf32?dmode=source&output=gplain

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00002.html

来源:REDHAT

链接:http://rhn.redhat.com/errata/RHSA-2013-0154.html

来源:SUSE

链接:http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00017.html

来源:SUSE

链接:http://lists.opensuse.org/opensuse-updates/2012-08/msg00046.html

漏洞信息快速查询

相关漏洞

更多