漏洞信息详情

Ekiga UTF-8 Parsing 输入验证漏洞

  • CNNVD编号:CNNVD-201212-066
  • 危害等级: 中危
  • CVE编号: CVE-2012-5621
  • 漏洞类型: 输入验证
  • 发布时间: 2012-12-06
  • 威胁类型: 远程
  • 更新时间: 2014-10-08
  • 厂        商: ekiga
  • 漏洞来源: Nicolas Sapa

漏洞简介

ekiga(前称GnomeMeeting)是比利时软件开发者Damien Sandras所研发的一套支持SIP和H.323协议的视频会议程序,它兼容VoIP和IP电话,并能够与使用SIP和H.323软硬件的远程用户进行视频和音频对话。

ekiga 4.0.0之前版本的lib/engine/components/opal/opal-call.cpp文件中存在安全漏洞,该漏洞源于程序没有正确处理带有无效UTF-8字符串的OPAL连接。远程攻击者可利用该漏洞造成拒绝服务(崩溃)。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://ftp.gnome.org/pub/gnome/sources/ekiga/4.0/ekiga-4.0.0.news

参考网址

来源:BID

链接:http://www.securityfocus.com/bid/56790

来源:MLIST

链接:http://seclists.org/oss-sec/2012/q4/407

来源:ftp.gnome.org

链接:http://ftp.gnome.org/pub/gnome/sources/ekiga/4.0/ekiga-4.0.0.news

来源:bugzilla.redhat.com

链接:https://bugzilla.redhat.com/show_bug.cgi?id=883058

来源:FEDORA

链接:https://lists.fedoraproject.org/pipermail/package-announce/2013-March/099554.html

来源:git.gnome.org

链接:https://git.gnome.org/browse/ekiga/commit/?id=7d09807257

来源:blogs.oracle.com

链接:https://blogs.oracle.com/sunsecurity/entry/cve_2012_5621_denial_of

来源:XF

链接:http://xforce.iss.net/xforce/xfdb/80640

受影响实体

漏洞信息快速查询

相关漏洞

更多