漏洞信息详情

Moodle Yahoo! YUI io.swf文件跨站脚本漏洞

  • CNNVD编号:CNNVD-201307-601
  • 危害等级: 中危
  • CVE编号: CVE-2013-4939
  • 漏洞类型: 跨站脚本
  • 发布时间: 2013-07-30
  • 威胁类型: 远程
  • 更新时间: 2019-11-08
  • 厂        商: yahoo
  • 漏洞来源:

漏洞简介

YUI是美国雅虎(Yahoo!)公司的一个开源的JavaScript和CSS库,它的作用是创建交互式Web应用程序。Moodle是澳大利亚马丁-多基马(Martin Dougiamas)博士开发的一套免费、开源的电子学习软件平台,也称课程管理系统、学习管理系统或虚拟学习环境。

Moodle和其他产品中使用的Yahoo! YUI 3.0.0至3.9.1版本中的IO Utility组件中的io.swf文件中存在跨站脚本漏洞。远程攻击者可通过URL中特制的字符串利用该漏洞注入任意Web脚本或HTML。以下版本中存在漏洞:Moodle 2.1.10及之前的版本,2.2.10及之前的2.2.x版本,2.3.7及之前的2.3.x版本,2.4.4及之前的2.4.x版本,2.5版本。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://yuilibrary.com/support/20130515-vulnerability/

参考网址

来源:CONFIRM

链接:https://moodle.org/mod/forum/discuss.php?d=232496

来源:MLIST

链接:https://lists.apache.org/thread.html/d8b9403dbab85a51255614949938b619bd03b1c944c76c48c6996a0e@%3Cdev.zookeeper.apache.org%3E

来源:MLIST

链接:https://lists.apache.org/thread.html/72837f969cdf9b63a7e7337edd069fa3b3950eea7c997cc2ff61aa0c@%3Cissues.zookeeper.apache.org%3E

来源:CONFIRM

链接:http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-39678

来源:CONFIRM

链接:http://yuilibrary.com/support/20130515-vulnerability/

受影响实体

漏洞信息快速查询

相关漏洞

更多