漏洞信息详情

GNU glibc 多个远程整数溢出漏洞

  • CNNVD编号:CNNVD-201309-413
  • 危害等级: 中危
  • CVE编号: CVE-2013-4332
  • 漏洞类型: 数字错误
  • 发布时间: 2013-08-20
  • 威胁类型: 远程
  • 更新时间: 2013-10-10
  • 厂        商: Gnu
  • 漏洞来源: Will Newton

漏洞简介

GNU C Library(又名glibc,libc6)是一种按照LGPL许可协议发布的开源免费的C语言编译程序。

GNU C Library 2.18之前版本中的malloc/malloc.c文件中存在整数溢出漏洞。上下文相关的攻击者可通过向(1)pvalloc,(2)valloc,(3)posix_memalign,(4)memalign或(5)aligned_alloc函数传递较大的值利用该漏洞造成拒绝服务(堆内存损坏)。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://www.openwall.com/lists/oss-security/2013/09/12/6

参考网址

来源: sourceware.org

链接:https://sourceware.org/bugzilla/show_bug.cgi?id=15857

来源: sourceware.org

链接:https://sourceware.org/bugzilla/show_bug.cgi?id=15856

来源: sourceware.org

链接:https://sourceware.org/bugzilla/show_bug.cgi?id=15855

来源: bugzilla.redhat.com

链接:https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2013-4332

来源: MLIST

名称: [oss-security] 20130912 Re: CVE Request: Three integer overflows in glibc memory allocator

链接:http://www.openwall.com/lists/oss-security/2013/09/12/6

来源: BID

名称: 62324

链接:http://www.securityfocus.com/bid/62324

漏洞信息快速查询

相关漏洞

更多