漏洞信息详情

HP Linux Imaging and Printing upgrade.py文件安全漏洞

  • CNNVD编号:CNNVD-201312-164
  • 危害等级: 中危
  • CVE编号: CVE-2013-6427
  • 漏洞类型: 代码注入
  • 发布时间: 2013-12-12
  • 威胁类型: 远程
  • 更新时间: 2013-12-12
  • 厂        商: hp
  • 漏洞来源:

漏洞简介

HP Linux Imaging and Printing(HPLIP)是美国惠普(HP)公司开发的一个项目,其目的是让Linux系统能够支持惠普的喷墨打印机和激光打印机的打印、扫描和传真功能。

HPLIP 3.x至3.13.11版本中的hp-upgrade服务中的upgrade.py文件中存在安全漏洞,该漏洞源于从http URL启动程序。攻击者可通过获取对客户端和服务器数据流的控制利用该漏洞实施中间人攻击,执行任意代码。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://sourceforge.net/projects/hplip/files/hplip/

参考网址

来源: bugzilla.novell.com

链接:https://bugzilla.novell.com/show_bug.cgi?id=853405

来源: MLIST

名称: [oss-security] 20131204 Re: CVE needed for hplip insecure auto update feature?

链接:http://openwall.com/lists/oss-security/2013/12/05/2

漏洞信息快速查询

相关漏洞

更多