漏洞信息详情

Xelerance Openswan IKEv2 输入验证漏洞

  • CNNVD编号:CNNVD-201411-450
  • 危害等级: 中危
  • CVE编号: CVE-2014-2037
  • 漏洞类型: 输入验证错误
  • 发布时间: 2014-02-18
  • 威胁类型: 远程
  • 更新时间: 2019-07-30
  • 厂        商: openswan
  • 漏洞来源: Paul Wouters

漏洞简介

Xelerance Openswan是加拿大Xelerance公司的一个基于FreeS/WAN项目的用于Linux系统下的IPSEC实现,它主要用于保证数据传输中的安全性、完整性等问题。

Xelerance Openswan 2.6.40版本中存在安全漏洞。远程攻击者可借助特制的IKEv2数据包利用该漏洞造成拒绝服务(空指针逆向引用和IKE守护进程重启)。(说明:该漏洞由于CVE-2013-6466的补丁没有完全修复)

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://lists.openswan.org/pipermail/users/2014-February/022898.html

参考网址

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2014/02/20/2

来源:MLIST

链接:https://lists.openswan.org/pipermail/users/2014-February/022898.html

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2014/02/18/1

来源:BID

链接:https://www.securityfocus.com/bid/65629

受影响实体

漏洞信息快速查询

相关漏洞

更多