漏洞信息详情

Linux kernel IPv6栈代码注入漏洞

  • CNNVD编号:CNNVD-201505-039
  • 危害等级: 低危
  • CVE编号: CVE-2015-2922
  • 漏洞类型: 代码注入
  • 发布时间: 2015-04-30
  • 威胁类型: 特定网络环境
  • 更新时间: 2020-03-04
  • 厂        商: redhat
  • 漏洞来源:

漏洞简介

Linux kernel是美国Linux基金会发布的开源操作系统Linux所使用的内核。NFSv4 implementation是其中的一个分布式文件系统协议。

Linux kernel 3.19.5及之前版本的IPv6栈的Neighbor Discovery ND)协议实现过程中的net/ipv6/ndisc.c文件中的‘ndisc_router_discovery’函数存在安全漏洞。远程攻击者可借助Router Advertisement(RA)消息中的‘hop_limit’值利用该漏洞重新配置hop-limit设置。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.19.6

参考网址

来源:www.ibm.com

链接:https://www.ibm.com/blogs/psirt/security-bulletin-ibm-integrated-management-module-ii-imm2-is-affected-by-a-vulnerability-with-the-ipv6-networking-support-cve-2015-2922/

受影响实体

漏洞信息快速查询

相关漏洞

更多