漏洞信息详情

多款Opto 22产品缓冲区错误漏洞

  • CNNVD编号:CNNVD-201505-328
  • 危害等级: 超危
  • CVE编号: CVE-2015-1006
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2015-04-30
  • 威胁类型: 远程
  • 更新时间: 2019-05-14
  • 厂        商:
  • 漏洞来源: Ivan Sanchez of Nu...

漏洞简介

OPTO 22 PAC Project Basic等都是美国OPTO 22公司的产品。PAC Project Basic和PAC Project Professional都是用于工业自动化的远程监控和数据采集应用。PAC Display Basic和PAC Display Professional都是用于构建人机界面应用程序与SNAP PAC系统进行通信的HMI软件包。

多款Opto 22产品中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。以下产品及版本受到影响:PAC Project Professional R9.4006之前版本,PAC Project Basic R9.4006之前版本,PAC Display Basic R9.4f之前版本,PAC Display Professional R9.4f之前版本,OptoOPCServer R9.4c之前版本,OptoDataLink R9.4d及之前版本。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://www.opto22.com/site/knowledgebase/kb_view_article.aspx?aid=2571

参考网址

来源:ics-cert.us-cert.gov

链接:https://ics-cert.us-cert.gov/advisories/ICSA-15-120-01

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2015-1006

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多