漏洞信息详情

PCRE‘find_fixedlength()’函数基于堆的缓冲区溢出漏洞

  • CNNVD编号:CNNVD-201507-249
  • 危害等级: 中危
  • CVE编号: CVE-2015-5073
  • 漏洞类型: 信息泄露
  • 发布时间: 2015-06-26
  • 威胁类型: 远程
  • 更新时间: 2015-07-09
  • 厂        商: pcre
  • 漏洞来源: Wen Guanxing from ...

漏洞简介

PCRE(Perl Compatible Regular Expressions)是软件开发者Philip Hazel所研发的一个使用C语言编写的开源正则表达式函数库。

PCRE中存在基于堆的缓冲区溢出漏洞。攻击者可利用该漏洞在受影响应用程序上下文中执行任意代码,也可能造成拒绝服务。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://vcs.pcre.org/pcre/code/trunk/ChangeLog?revision=1609&view=markup

参考网址

来源:www-01.ibm.com

链接:http://www-01.ibm.com/support/docview.wss?uid=isg3T1023886

来源:vcs.pcre.org

链接:http://vcs.pcre.org/pcre?view=revision&revision=1571

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2015/06/26/1

来源:SECTRACK

链接:http://www.securitytracker.com/id/1033154

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2015/06/26/3

来源:BID

链接:http://www.securityfocus.com/bid/75430

来源:bugs.exim.org

链接:https://bugs.exim.org/show_bug.cgi?id=1651

来源:vcs.pcre.org

链接:http://vcs.pcre.org/pcre/code/trunk/ChangeLog?revision=1609&view=markup

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多