漏洞信息详情

Ignite Realtime Openfire 多个跨站脚本漏洞

  • CNNVD编号:CNNVD-201509-198
  • 危害等级: 中危
  • CVE编号: CVE-2015-6972
  • 漏洞类型: 跨站脚本
  • 发布时间: 2015-09-17
  • 威胁类型: 远程
  • 更新时间: 2015-09-17
  • 厂        商: igniterealtime
  • 漏洞来源:

漏洞简介

Ignite Realtime Openfire(前称Wildfire)是IgniteRealtime社区的一款采用Java开发且基于XMPP(前称Jabber,即时通讯协议)的跨平台开源实时协作(RTC)服务器,它能够构建高效率的即时通信服务器,并支持上万并发用户数量。

Ignite Realtime Openfire 3.10.2版本中存在多个跨站脚本漏洞,这些漏洞源于plugins/clientcontrol/create-bookmark.jsp脚本没有充分过滤‘groupchatName’参数;plugins/clientcontrol/create-bookmark.jsp脚本没有充分过滤‘urlName’参数;server-session-details.jsp脚本没有充分过滤‘hostname’参数;group-summary.jsp脚本没有充分过滤‘search’参数。远程攻击者可利用该漏洞注入任意Web脚本或HTML。

漏洞公告

目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:

http://www.igniterealtime.org/projects/openfire/

参考网址

来源:packetstormsecurity.com

链接:http://packetstormsecurity.com/files/133558/Openfire-3.10.2-Cross-Site-Scripting.html

来源:hyp3rlinx.altervista.org

链接:http://hyp3rlinx.altervista.org/advisories/AS-OPENFIRE-XSS.txt

来源:EXPLOIT-DB

链接:https://www.exploit-db.com/exploits/38191/

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多