漏洞信息详情

WordPress Pie Register插件跨站脚本漏洞

  • CNNVD编号:CNNVD-201510-303
  • 危害等级: 中危
  • CVE编号: CVE-2015-7377
  • 漏洞类型: 跨站脚本
  • 发布时间: 2015-10-19
  • 威胁类型: 远程
  • 更新时间: 2015-10-19
  • 厂        商: genetechsolutions
  • 漏洞来源:

漏洞简介

WordPress是WordPress软件基金会的一套使用PHP语言开发的博客平台,该平台支持在PHP和MySQL的服务器上架设个人博客网站。Pie Register是其中的一个支持自定义会员注册登陆页面的插件。

WordPress Pie Register插件2.0.19之前版本的pie-register/pie-register.php脚本中存在跨站脚本漏洞,该漏洞源于程序没有充分过滤pie-register页面中的‘invitaion_code’参数。远程攻击者可利用该漏洞注入任意Web脚本或HTML。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://github.com/GTSolutions/Pie-Register/blob/2.0.19/readme.txt

参考网址

来源:BUGTRAQ

链接:http://www.securityfocus.com/archive/1/archive/1/536668/100/0/threaded

来源:github.com

链接:https://github.com/GTSolutions/Pie-Register/blob/2.0.19/readme.txt

来源:wpvulndb.com

链接:https://wpvulndb.com/vulnerabilities/8212

来源:packetstormsecurity.com

链接:http://packetstormsecurity.com/files/133928/WordPress-Pie-Register-2.0.18-Cross-Site-Scripting.html

漏洞信息快速查询

相关漏洞

更多