漏洞信息详情

Apache Solr Admin UI 跨站脚本漏洞

漏洞简介

Apache Solr是美国阿帕奇(Apache)软件基金会的一款基于Lucene(一个全文检索引擎的架构)的搜索服务器,它支持层面搜索、垂直搜索、高亮显示搜索结果、多种输出格式等。Admin UI是其中的一个管理员和程序员管理Solr配置的Web界面。

Apache Solr 5.3之前版本的Admin UI中的webapp/web/js/scripts/schema-browser.js文件中存在跨站脚本漏洞。远程攻击者可借助特制的schema-browse URL利用该漏洞注入任意Web脚本或HTML。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://issues.apache.org/jira/browse/SOLR-7920

参考网址

来源:issues.apache.org

链接:https://issues.apache.org/jira/browse/SOLR-7920

受影响实体

漏洞信息快速查询

相关漏洞

更多