漏洞信息详情

Perl 安全漏洞

  • CNNVD编号:CNNVD-201604-198
  • 危害等级: 高危
  • CVE编号: CVE-2015-8608
  • 漏洞类型: 资料不足
  • 发布时间: 2015-11-28
  • 威胁类型: 远程
  • 更新时间: 2017-02-08
  • 厂        商: Perl
  • 漏洞来源: John Leitch (john@...

漏洞简介

Perl是美国程序员拉里-沃尔(Larry Wall)所研发的一种免费且功能强大的跨平台编程语言。

Perl 5.22版本中的‘VDir::MapPathA’和‘VDir::MapPathW’函数存在安全漏洞。远程攻击者可利用该漏洞造成拒绝服务(越边界读取),也可能执行任意代码。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://rt.perl.org/Public/Bug/Display.html?id=126755

参考网址

来源:autosectools.com

链接:http://autosectools.com/Perl-VDir-MapPath-Out-of-bounds-Read

来源:rt.perl.org

链接:https://rt.perl.org/Public/Bug/Display.html?id=126755

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/136649/Perl-5.22-VDir-MapPathA-W-Out-Of-Bounds-Reads-Buffer-Over-Reads.html

受影响实体

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多