漏洞信息详情

Ikiwiki 跨站脚本漏洞

  • CNNVD编号:CNNVD-201605-177
  • 危害等级: 中危
  • CVE编号: CVE-2016-4561
  • 漏洞类型: 跨站脚本
  • 发布时间: 2016-05-09
  • 威胁类型: 远程
  • 更新时间: 2016-05-11
  • 厂        商: ikiwiki
  • 漏洞来源:

漏洞简介

Ikiwiki是软件开发者Joey和其他贡献者共同开发的一款wiki编译器,它支持将wiki页面转换为网站发布的HTML页面。

Ikiwiki 3.20160506之前版本的CGI.pm文件中的‘cgierror’函数存在跨站脚本漏洞。远程攻击者可借助错误消息利用该漏洞利用该漏洞注入任意Web脚本或HTML。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://ikiwiki.info/security/#index43h2

参考网址

来源:source.ikiwiki.branchable.com

链接:http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=32ef584dc5abb6ddb9f794f94ea0b2934967bba7

来源:ikiwiki.info

链接:http://ikiwiki.info/security/#index43h2

来源:DEBIAN

链接:http://www.debian.org/security/2016/dsa-3571

来源:www.auscert.org.au

链接:https://www.auscert.org.au/render.html?it=34190

受影响实体

漏洞信息快速查询

相关漏洞

更多