漏洞信息详情

libimobiledevice和libusbmuxd 安全漏洞

  • CNNVD编号:CNNVD-201605-663
  • 危害等级: 中危
  • CVE编号: CVE-2016-5104
  • 漏洞类型: 资料不足
  • 发布时间: 2016-05-27
  • 威胁类型: 远程
  • 更新时间: 2020-03-02
  • 厂        商: novell
  • 漏洞来源:

漏洞简介

libimobiledevice是一个可让Linux支持连接iPhone、iPodTouch等iOS设备的软件协议库和工具。libusbmuxd是一个用于与iOS设备连接的客户端库。

libimobiledevice和libusbmuxd的common/socket.c文件中的‘socket_create’函数存在安全漏洞。远程攻击者可通过连接IPv4 TCP套接字利用该漏洞绕过既定的访问限制,与iOS设备上的服务进行通信。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://github.com/libimobiledevice/libimobiledevice/commit/df1f5c4d70d0c19ad40072f5246ca457e7f9849e

https://github.com/libimobiledevice/libusbmuxd/commit/4397b3376dc4e4cb1c991d0aed61ce6482614196

参考网址

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2020.0728/

漏洞信息快速查询

相关漏洞

更多