漏洞信息详情

Linux kernel 安全漏洞

  • CNNVD编号:CNNVD-201612-084
  • 危害等级: 高危
  • CVE编号: CVE-2016-9793
  • 漏洞类型: 缓冲区溢出
  • 发布时间: 2016-12-07
  • 威胁类型: 本地
  • 更新时间: 2016-12-29
  • 厂        商: linux
  • 漏洞来源: Syzkaller team.

漏洞简介

Linux kernel是美国Linux基金会发布的开源操作系统Linux所使用的内核。NFSv4 implementation是其中的一个分布式文件系统协议。

Linux kernel 4.8.13及之前的版本中的net/core/sock.c文件的‘sock_setsockopt’函数存在安全漏洞,该漏洞源于程序没有正确的处理‘sk_sndbuf’和‘sk_rcvbuf’的负值。本地攻击者可利用该漏洞造成拒绝服务(内存损坏和系统崩溃)。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.14

参考网址

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2016/12/03/1

来源:git.kernel.org

链接:http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=b98b0bc8c431e3ceb4b26b0dfc8db509518fb290

来源:www.kernel.org

链接:http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.14

来源:bugzilla.redhat.com

链接:https://bugzilla.redhat.com/show_bug.cgi?id=1402013

来源:github.com

链接:https://github.com/torvalds/linux/commit/b98b0bc8c431e3ceb4b26b0dfc8db509518fb290

来源:BID

链接:http://www.securityfocus.com/bid/94655

受影响实体

漏洞信息快速查询

相关漏洞

更多