漏洞信息详情

libpng 安全漏洞

  • CNNVD编号:CNNVD-201612-817
  • 危害等级: 中危
  • CVE编号: CVE-2016-10087
  • 漏洞类型: 资料不足
  • 发布时间: 2016-12-30
  • 威胁类型: 远程
  • 更新时间: 2017-02-23
  • 厂        商: Libpng
  • 漏洞来源:

漏洞简介

libpng是一个可对PNG图形文件实现创建、读写等操作的PNG参考库。

libpng中的‘png_set_text_2’函数存在安全漏洞。攻击者可利用该漏洞造成拒绝服务(空指针逆向引用)。以下版本受到影响:libpng 1.0.67之前的版本,1.2.57之前的1.2.x版本,1.4.20之前的1.4.x版本,1.5.28之前的1.5.x版本,1.6.27之前的1.6.x版本。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:

http://www.libpng.org/pub/png/libpng.html

参考网址

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2016/12/29/2

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2016/12/30/4

来源:BID

链接:http://www.securityfocus.com/bid/95157

补丁

    暂无

漏洞信息快速查询

相关漏洞

更多