漏洞信息详情

KDE kio和kdelibs 安全漏洞

  • CNNVD编号:CNNVD-201703-016
  • 危害等级: 中危
  • CVE编号: CVE-2017-6410
  • 漏洞类型: 其他
  • 发布时间: 2017-03-02
  • 威胁类型: 本地
  • 更新时间: 2019-10-23
  • 厂        商: kde
  • 漏洞来源:

漏洞简介

KDE kio是一个包含在KDE Frameworks 5和KDE Software Compilation 4中的系统库。kdelibs是一个用于在Qt框架上创建和开发KDE软件的库。

KDE kio 5.32之前的版本和kdelibs 4.14.30之前的版本中的kpac/script.cpp文件存在安全漏洞,该漏洞源于程序使用完整的https URL(包括基本的身份验证证书、查询字符串或PATH_INFO)调用‘PAC FindProxyForURL’函数。远程攻击者可借助特制的PAC文件利用该漏洞获取敏感信息。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://www.kde.org/info/security/advisory-20170228-1.txt

参考网址

来源:DEBIAN

链接:https://www.debian.org/security/2017/dsa-3849

来源:CONFIRM

链接:https://www.kde.org/info/security/advisory-20170228-1.txt

来源:BID

链接:https://www.securityfocus.com/bid/96515

受影响实体

漏洞信息快速查询

相关漏洞

更多