漏洞信息详情

Oniguruma 安全漏洞

漏洞简介

mbstring(Multi-Byte String)是PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)中的一个语言编码扩展库;Oniguruma-mod是Ruby(编程语言)中的一个正则表达式库。Oniguruma是其中的一个正则表达式引擎。

Ruby 2.4.1及之前的版本的Oniguruma-mod和PHP 7.1.5及之前的版本的mbstring中使用的Oniguruma 6.2.0版本的‘mbc_enc_len()’函数存在安全漏洞。攻击者可利用该漏洞造成栈越边界读取。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

https://github.com/kkos/oniguruma/commit/9690d3ab1f9bcd2db8cbe1fe3ee4a5da606b8814

参考网址

来源:CONFIRM

链接:https://github.com/kkos/oniguruma/commit/9690d3ab1f9bcd2db8cbe1fe3ee4a5da606b8814

来源:CONFIRM

链接:https://github.com/kkos/oniguruma/issues/58

漏洞信息快速查询

相关漏洞

更多