漏洞信息详情

PHP 缓冲区错误漏洞

漏洞简介

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。

PHP中的Zend/zend_ini_parser.c文件的‘zend_ini_do_op()’函数存在基于栈的缓冲区溢出漏洞。攻击者可利用该漏洞造成拒绝服务或可能执行代码。以下版本受到影响:PHP 5.6.31之前的版本,7.0.21之前的7.x版本,7.1.7之前的7.1.x版本。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://bugs.php.net/bug.php?id=74603

参考网址

来源:MISC

链接:http://git.php.net/?p=php-src.git;a=commit;h=05255749139b3686c8a6a58ee01131ac0047465e

来源:MISC

链接:http://git.php.net/?p=php-src.git;a=commit;h=5f8380d33e648964d2d5140f329cf2d4c443033c

来源:MISC

链接:https://bugs.php.net/bug.php?id=74603

漏洞信息快速查询

相关漏洞

更多